nix-flake-examples/python/flake.nix
2023-12-19 13:45:24 -08:00

24 lines
616 B
Nix

{
description = "Good basic flake template";
inputs = {
nixpkgs.url = "nixpkgs/nixpkgs-unstable";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem (system:
let
systempkgs = nixpkgs.legacyPackages.${system};
in
{
devShells.default = systempkgs.mkShell {
buildInputs = with systempkgs; [
python3
# This probably needs other stuff, like flake8
python311Packages.python-lsp-server
];
};
}
);
}